It has been long time that I though to write this post when my brother faced issue on his Google Chrome could not see the Khmer character (Khmer Unicode) and in fact all other Unicode characters such Chinese or Thai.

We first say, it’s because of Khmer Unicode issue on Chrome but in fact, it was not.

The real issue and solution because of the settings of Chrome does not allow the render.

Please type on Google Chrome’s address bar: chrome://flags and search for DirectWrite Windows

Disables DirectWrite Windows
Disables the use of experimental DirectWrite font rendering system. #disable-direct-write

You would see a button to Enable it, just do it and click relaunch.

It was solved the issue.

Khmer Unicode Render Solution on Google Chrome

Note:

I tried to disable it to reproduce the issue on my Windows 8-32bit, I still can see Khmer Unicode but it was confirmed from my brother that it’s impacted on his Windows 8-64bit on Unicode rendering.

So, if you have this problem, let’s try and let’s share your result in comment if any.