On my Windows 10 Pro / Microsoft Surface 6 Pro, I did a setup wrong from the beginning to select UK as my language/keyboard and it’s likes nightmare as I cannot completely remove it, it did remove each time I tried around such as follow this post, or this post, etc. as it may randomly or after Windows update to go back to the same state.

Here is my problem, too many language appear in the language bar, I just want: English (United State), Khmer Angkor, Thai as example;

My case, I want completely remove English (United Kingdom) as I don’t know how to use the keyboard layout.

What finally I think it solved (to re-confirm whenever I have new Windows update), as following way:

  1. I tried to remove all input keyboard/language via Control Panel > Settings > Language etc.
  2. I install Keyboard/language: English (United State) and put it as default
  3. I attach region to the correct country
  4. Then I go to Control Panel again > Regions, Click on it and go to tab: Administrative, click on Copy Settings, originally I see that:
    • Current User is pointing to English (United Kingdom)
    • Welcome screen is English (United State)
    • New user account is English (United Kingdom)
  5. So that, I change the setting by click Copy your current setting for (see below picture):
    • Welcome screen and system accounts
    • New user account
  6. You will see if the language from those 3 points are presenting correctly, then click OK and restart your PC
What we need to do

After restart, I could see that I have withdraw the language I want it out

Then, we can re-install the language we want and it’s back as expected

Published by osify

Find us via: Twitter, Facebook

Leave a comment

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.