How to fix “Current Profile Has no WMI enable” – MySQL Workbench

On My SQL Workbench 5.x or 6.x, to manage the administration stuff such as import/export.

Somehow, you could face an error when click on those admin tool:

Current Profile Has no WMI enable


To solve this, it’s simply :


  • On MySQL Workbench: Server Administration (on the right column)
  • Click Manage Server Instances
  • Select System Profile tab
  • Check box(es) to acquire Admin privileges

See attachment:



Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.